Skocz do zawartości
Forum komputerowe PC Centre

Rekomendowane odpowiedzi

Witam , mam maly problem z predkoscia gry. Mianowicie zbyt wysoki ping!

Poczatkowo myslalem, ze to wina starego routera wiec kupilem nowy , model :

 

Netgear N300 adsl2+ modem router , DGNB2200 .

 

porty ktore nalezy forwardowac w grze sa nastepujace :

 

TCP: 80, 443, 64100, 6667, 29900, 2990, 28910

UDP: 27900, 27901, 64100

 

w trakcie gry wyswietla mi komunikat :

 

Nat - ograniczony , kiedy wchodzac na router wylaczam funkcje NAT, to automatycznie pomimo polaczenia z internetem nie otwieraja mi sie strony ... (teraz mnie tak olsnilo - czy po wylaczeniu tej funkcji trzeba uaktywnic port 80 ? to jest chyba port przegladarki itp) ale mniejsza z tym .

 

Moje pytanie to : Jak ustawic forwardowanie portow tcp i udp prawidlowo by ping zszedl ponizej 150 ? dodam tylko ze czasem w trakcie rozgrywki rosnie on tak wysoko , ze zostaje wyrzucony z serwera :/

 

Ps. mam na routerze dwie opcje : port forwarding , port triggering.

 

a ustawilem je tak , port triggering:

 

post-11819-0-41315200-1313166400_thumb.png

 

port forwarding :

 

post-11819-0-21851600-1313166432_thumb.png

 

prosze o porady...

 

Ps2 . poczatkowo umiescilem tego posta w grach komputerowych ale ten temat wydaje mi sie bardziej trafny.

Udostępnij tę odpowiedź


Odnośnik do odpowiedzi
Udostępnij na innych stronach

Pierwsza sprawa: jakie dokładnie łącze posiadasz? Ktoś korzysta z łącza oprócz ciebie?

Druga sprawa: jak przekierowujesz porty to korzystasz tylko z jednej techniki (nie z obu!). Polecam wykorzystać zwykły port forwarding (czyli wywalić wpisy z port triggering i dodać co trzeba do forwardowania).

Rada odnośnie przekierowania portów 80, 443 nie wydaje się zbyt rozsądna - no chyba, że crysis 2 działa jako serwer www...

 

Co do wyłączania NATowania to nie ma to najmniejszego sensu dopóki ciągle używa się IPv4 (miałoby to sens w wypadku posiadania kilku adresów zewnętrznych, etc.). Ogólnie to głębszy temat i tak na same opóźnienia ma minimalny wpływ.

 

Jaki masz ping np. wp.pl / onet.pl / etc.

 

Inna sprawa to sama jakość połączenia serwerów do których się łączysz, z tego co na szybko przeczytałem ludzie na zachodzie nie uświadczają pingów niższych niż 100 ms. Mówiąc inaczej - nawet jeżeli problem jest po twojej stronie to i tak nic nie poradzisz na opóźnienia jeżeli serwer nie nadąża (zapchane łącze, zasoby, etc.)

Udostępnij tę odpowiedź


Odnośnik do odpowiedzi
Udostępnij na innych stronach

speedtest.net wykazuje ping 15ms . download troszke ponad 10 Mbps . upload niecaly 1.0 Mbps (przy dobrych wiatrach) .

(wydaje mi sie , ze jest to osmio megowe lacze)

 

Z routera korzysta tez jeden uzytkownik - laczy sie wi fi z laptopem. Ale to nie jest problemem gdyz nawet pozna pora gdy tylko ja uzywalem (na nowym routerze) lacza uzyskiwalem ping od 429 poprzez 799 az po grubo ponad 1000 ms na liscie serwerow. dodam , ze chyba masz racje co do pingu w granicy 100 ms gdyz wczesniej mialem ping na starym routerze 108 ms (to byl najnizszy, ktory czesto pojawial sie na starcie na serwerach).

 

Sprawdze Twoj pomysl i zostawie tylko forwarding ..

 

mam jeszcze jedno pytanie - nie zmienialem zadnych ustawien co do IP . Jak sie zorientowalem serwer dhcp przydziela je automatycznie.

Czy ustawienie stalego ip moze poprawidz dzialanie internetu ? a co za tym idzie czy jest to trudne do wykonania .. w sumie to nie kontynuuje bo z pytania rodzi mi sie kolejne pytanie ;) .. ok mam nadzieje ze forward zadziala .

 

Dziekuje !

Michal .

Udostępnij tę odpowiedź


Odnośnik do odpowiedzi
Udostępnij na innych stronach

DHCP służy do autokonfiguracji połączenia (tutaj lokalnego) i nie ma ono kompletnie żadnego wpływu na szybkość działania internetu (konfiguracja odbywa się przy starcie systemu - nawiązaniu połączenia, a później tylko szybkie odnowienie po okresie dzierżawy - z reguły ok 24h).

 

Jeżeli również korzystasz z laptopa, czy też komputera z kartą WiFi to jeszcze testowo możesz spróbować podpiąć się zwykłym kablem ethernetowym do routera i sprawdzić czy będzie jakaś różnica.

 

Jeszcze mała uwaga - aby forwardowanie działało to oczywiście komputer, na który przekierowujesz porty musi mieć przypisany dany adres IP (np. 192.168.0.2), gdyż jeżeli dostanie inny adres z puli to przekierowanie nie działa. W routerze powinno być coś na styl address reservation, static dhcp, etc. co pozwala na przypisanie danego adresu IP do danego adresu MAC (czyli komputer o takiej a takiej karcie sieciowej dostanie zawsze ten sam adres IP). W przeciwnym wypadku trzeba się ratować ustawieniem statycznego adresu IP co rodzi kilka problemów i nie jest wygodne...

Udostępnij tę odpowiedź


Odnośnik do odpowiedzi
Udostępnij na innych stronach

tak wczoraj myslalem... ( a co jesli ktos inny polaczy sie pierwszy z routerem i dostanie adres xxx.xxx.0.2 i znalazlem opcje address reservation uzylem tego. ) dopiero dzisiaj udalo mi sie sprawic by ping byli niski - niestety nie wiem do konca jak to zrobilem bo wylaczalem kilka opcji naraz ... [najwazniejsze ze dziala - ale milo jest zrozumiec w jaki sposob] .

 

Ps. Qos - to jest opcja ktora pozwala ustawic priorytety na poszczegolne aplikacje sieciowe, sprawdzilem liste i sa tam m.in. FTP, WWW, Kazaa, Quake itp i 15 innych ... moje pytanie : czy gdybym na te liste wstawil aplikacje (gre) o ktora mi chodzi i ustawil jej priorytet na high to w momencie gdy inni uzytkownicy routera sie lacza ja bede mial 'pierwszenstwo' co do lacza ?

 

Disable Port Scan and DoS Protection - wylaczylem te opcje bo sa to pewnego rodzaju zabezpieczenia czy one maja wplyw na ping ?

 

NAT Filtering - z opcji secured przelaczylem na open . (niestety w grze dalej pojawia mi sie komunikat w rogu ( NAT- ograniczony [ i

nie mam pojecia jak sprawic by nie byl ograniczony])

Disable SIP ALG - ta opcja ma wplyw na aplikacje typu skype (wylaczylem ja mimo wszystko - ale niedlugo sam bede musial skype

zainstalowac , mam nadzieje , ze to nie bedzie niwelowalo dzialania programu )

 

I jak jeszcze mozna to moje ostatnie pytanie . UDP i TCP .

Gra ma wyrazne instrukcje :

port udp : xxx.xxxxx. .xxxx. xxxx. xx (gdzie x to ogolnie numer portu udp)

port tcp : yyy. yy .yyyyyy .yyy .yyy (gdzie y to ogolny numer portu tcp )

 

gdy forwarduje port moge wybrac opcje : tcp , udp , tcp/udp . (3 opcje)

 

wybierajac opcje tcp/udp moge wpisac tylko jeden port np : xxx wiec w jaki sposob udp sie aktywuje ? chodzi mi o to ze opcja jest dla obu udp i tcp a port ktory moge wprowadzic to tylko sam UDP lub TCP .

 

ojej troche to nagmatwane ale takie logiczne podejscie mi sie nasuwa.

Udostępnij tę odpowiedź


Odnośnik do odpowiedzi
Udostępnij na innych stronach

Mogą mieć (dodatkowe obciążenie dla pudełka bo analizuje ruch). Choć prędzej ma to wpływ na zrywanie połączenia jeżeli router uzna, że ruch jest kwalifikowany jako atak DoS.

 

Co do NAT ograniczony to chyba zawsze się pojawia dopóki jesteś za NATem (jakbyś miał zewn. IP przypisane do komputera to może wtedy by to znikło). Ogólnie - olej ten komunikat.

 

Jeżeli wybierzesz TCP/UDP to port protokołu TCP, jak i UDP będzie otwarty. Jak tylko UDP, czy też tylko TCP to tylko danego protokołu. Skoro jest podane jaki protokół to nie musisz wybierać TCP/UDP.

 

Odnośnie samego QoS'a to możesz spróbować to włączyć, ale ustaw też priorytety dla innych rzeczy. Na przykład:

gra - najwyższy

www - średni

poczta - średni

p2p, etc. - najniższy...

Udostępnij tę odpowiedź


Odnośnik do odpowiedzi
Udostępnij na innych stronach

Ustawilem protokól UDP/TCP a oprucz tego osobny port na TCP i osobny port na UDP (przy czym wszystkie 3 sa rozne od siebie) moze to stwarzac jakiegos rodzaju konflikt ?

 

a i dziekuje za wspomnienie o zerwaniu polaczenia - zdarzylo mi sie to dwa razy podczas grania -teraz wiem ze to byla prawdopodobnie interwencja programu routera na atak z zewnatrz

 

Obecnie ping schodzi juz na granice 41ms co jest wiecej niz zadowalajace. Dziekuje bardzo za pomoc .

 

Michal.

 

Ps . -----> Nerio = Guru wink.png

Udostępnij tę odpowiedź


Odnośnik do odpowiedzi
Udostępnij na innych stronach

Daj zrzut ekranowy z tej konfiguracji, wtedy będzie łatwiej coś powiedzieć..

Udostępnij tę odpowiedź


Odnośnik do odpowiedzi
Udostępnij na innych stronach

witam po raz kolejny , nie wiem czy to wylaczenie i wlaczenie routera ta podzialalo ale ale wszystko chodzi strasznie opornie. Musze czekac nawet na google by mi sie otworzylo :/ od dostawcy sieci do routera nie ma problemu:

post-11819-0-97790500-1313417106_thumb.png

wyraznie pokazuje wysoki transfer danych. a informacje ktore podaje mi speedtest to jakies nieporozumienie:

post-11819-0-05593300-1313417229_thumb.png :/

gra rowniez nie chodzi jak powinna ping w granicach 800 sad.png porobilem pare zrzutow z ustawien i naprawde nie wiem co moze powodowac taka kolizje sad.png

Kolejno :

forwardowanie portow

post-11819-0-89419500-1313417089_thumb.png

Basic Settings

post-11819-0-73924600-1313417083_thumb.png

Adsl Settings

post-11819-0-35465700-1313417079_thumb.png

Wireless Settings

post-11819-0-77176600-1313417122_thumb.png

 

Wan

post-11819-0-54277100-1313417116_thumb.png

Lan

post-11819-0-50351900-1313417095_thumb.png

Qos

post-11819-0-55682400-1313417104_thumb.png ,

post-11819-0-26905100-1313417100_thumb.png

 

Status routera:

post-11819-0-47094000-1313417111_thumb.png

 

Prosze o wskazowki na dobra konfiguracje, nie mam pojecia dlaczego wszystko nagle tak zamulilo .

Udostępnij tę odpowiedź


Odnośnik do odpowiedzi
Udostępnij na innych stronach

QoS - strasznie dużo wpisów masz...

Testowo wyłącz QoS i uruchom ponownie router (po zapisaniu zmian). Jeżeli nadal będzie wolno działać to raczej doszukiwałbym się problemów u usługodawcy (btw. kto jest dostawcą internetu? Netia? TP?), gdyż raczej wszystko wygląda ok. Ewentualnie pytanie takie: to się dzieje na kablu i na WiFi czy tylko na WiFi? Pokaż co masz w logach, block sites i block services...

Udostępnij tę odpowiedź


Odnośnik do odpowiedzi
Udostępnij na innych stronach

chyba udalo mi sie znalesc serce problemu. .. w nocy po pracy po zalogowaniu na router dostrzeglem dodatkowego uzytkownika o IP 192.168.0.6 - po paru minutach to IP zniknelo z listy... zmienilem haslo dostepu do sieci i wszystko zaczelo ponownie chodzic szybko - wydaje mi sie, ze mialem jakiegos zlodzieja transferu ktory zapychal mi lacze. teraz problem zniknal. Ale mimo wszystko zalecasz aby pousuwac listy Qos-a ? one byly tam umieszczone automatycznie.

Ps. jestem polaczony do routera na kablu , inni uzytkownicy to wi-fi .

Udostępnij tę odpowiedź


Odnośnik do odpowiedzi
Udostępnij na innych stronach

Jak miałeś proste hasło na WiFi to pewnie nie było problemu z jego złamaniem...

Skoro teraz działa to nie widzę konieczności ruszania QoS'a.

Udostępnij tę odpowiedź


Odnośnik do odpowiedzi
Udostępnij na innych stronach

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Gość
Dodaj odpowiedź do tematu...

×   Wklejono zawartość z formatowaniem.   Usuń formatowanie

  Dozwolonych jest tylko 75 emoji.

×   Odnośnik został automatycznie osadzony.   Przywróć wyświetlanie jako odnośnik

×   Przywrócono poprzednią zawartość.   Wyczyść edytor

×   Nie możesz bezpośrednio wkleić grafiki. Dodaj lub załącz grafiki z adresu URL.

Ładowanie

×
×
  • Dodaj nową pozycję...